Skip to main content
VulnerabilityPublished Updated

CVE-2025-40246: linux-gcp-6.17, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.17.0-1009.9~24.04.3 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:29 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-1009.9~24.04.3, 6.17.0-1008.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.17.0-1009.9~24.04.3 (linux-gcp-6.17 package) or 6.17.0-1008.9 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.9
Fixed in
  • 6.17.0-1008.9
Ubuntu 24.04 LTSlinux-gcp-6.17pkg:deb/ubuntu/linux-gcp-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1009.9~24.04.3
Fixed in
  • 6.17.0-1009.9~24.04.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released updated Linux kernel packages (linux-gcp-6.17 versions 6.17.0-1009.9~24.04.3 and 6.17.0-1008.9) that address these vulnerabilities. Users should update their systems using standard system update procedures and reboot to apply all changes. Note that due to an ABI change, third-party kernel modules must be recompiled and reinstalled after the update. Refer to the Ubuntu security notice USN-8094-2 for detailed update instructions.

Description

Multiple vulnerabilities were discovered in the Linux kernel, including issues in the AppArmor Linux Security Module that could allow unprivileged local attackers to manipulate AppArmor profiles, potentially causing denial of service, information disclosure, local privilege escalation, or container escape. Additionally, some AMD Zen 5 processors with RDSEED instruction had entropy handling flaws that could lead to compromised randomness, affecting confidentiality and integrity. Numerous other kernel subsystems and drivers were also affected by various security flaws.

References

Community reviews

Loading reviews…