CVE-2024-36347: linux-gcp, linux-gcp-6.17 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 6.4 Medium · fixed in 6.17.0-1012.12~24.04.1 : update Linux kernel when convenient.
Data as of 3 Nov 2026, 17:32 UTC
- Patch
- Available – fixed in 6.17.0-1012.12~24.04.1, 6.17.0-1012.12
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.17.0-1012.12~24.04.1 (linux-gcp-6.17 package) or 6.17.0-1012.12 (linux-gcp package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcp-6.17pkg:deb/ubuntu/linux-gcp-6.17?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update their linux-gcp kernel packages to version 6.17.0-1012.12 or later (including 6.17.0-1012.12~24.04.1 for Ubuntu 24.04 LTS). After updating, a system reboot is required to apply the fixes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow the official Ubuntu security notice USN-8183-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Google Cloud Platform (linux-gcp-6.17), including a critical flaw named EntrySign affecting some AMD Zen processors. EntrySign involves improper verification of CPU microcode signatures, allowing a privileged attacker to load malicious microcode, potentially compromising system integrity and confidentiality. Additionally, numerous other vulnerabilities affect a wide range of kernel subsystems and drivers. These issues could allow attackers to compromise affected systems. Fixes have been released and are available in updated linux-gcp kernel packages.
References
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-36347 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68351 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68353 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68365 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68368 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68725 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68745 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68767 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68768 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68769 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68770 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68771 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68772 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68773 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68774 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68775 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68776 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68777 (opens in a new tab)