CVE-2025-38003: linux-gke, linux-kvm vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1087.93 : patch Linux kernel soon.
Data as of 3 Nov 2026, 17:44 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 5.15.0-1087.93, 5.15.0-1086.91
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 5.15.0-1087.93 (linux-gke package) or 5.15.0-1086.91 (linux-kvm package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinux-kvmpkg:deb/ubuntu/linux-kvm?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by Ubuntu by updating to linux-image versions 5.15.0-1086.91 or 5.15.0-1087.93 or later. After updating, reboot the system to activate the fixes. Recompile and reinstall any third-party kernel modules due to ABI changes introduced by the update. Following these steps will mitigate the vulnerabilities.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems including cryptographic APIs, various device drivers, file systems, and networking components. These flaws could potentially allow an attacker to compromise the affected system. The issues have been addressed in updated Linux kernel versions, and users are advised to apply these updates and reboot their systems. Due to ABI changes, recompilation of third-party kernel modules is necessary after updating.
References
- ubuntu.com/security/notices/USN-7704-5 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38003 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38004 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38031 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38034 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38035 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38037 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38043 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38044 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38048 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38051 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38052 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38058 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38061 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38065 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38066 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38068 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38072 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38075 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38077 (opens in a new tab)