CVE-2024-57996: linux-ibm, linux-ibm-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.8.0-1037.37~22.04.1 : patch Linux kernel soon.
Data as of 31 Oct 2026, 01:36 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-1037.37~22.04.1, 6.8.0-1037.37
Exploitation evidence
Disclosed: evidence found.
CVE published 25 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.0-1037.37~22.04.1 (linux-ibm-6.8 package) or 6.8.0-1037.37 (linux-ibm package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinux-ibm-6.8pkg:deb/ubuntu/linux-ibm-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official security updates provided by Ubuntu for linux-ibm-6.8 kernel packages to versions 6.8.0-1037.37 and 6.8.0-1037.37~22.04.1 or later. After updating, reboot the system to activate the fixes. Due to ABI changes, recompile and reinstall all third-party kernel modules. Follow the update instructions in the Ubuntu security notice USN-7779-1 at https://ubuntu.com/security/notices/USN-7779-1.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures including ARM32, ARM64, x86, various device drivers, networking components, and file systems. These flaws could potentially allow an attacker to compromise the affected system. Updates correcting these issues have been released for the linux-ibm-6.8 kernel packages. Users should apply the updates and reboot to ensure the fixes take effect.
References
- ubuntu.com/security/notices/USN-7779-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-57996 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58090 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21872 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21873 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21875 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21877 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21878 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21880 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21881 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21883 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21885 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21887 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21888 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21889 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21890 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21891 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21892 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21894 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21895 (opens in a new tab)