Skip to main content
VulnerabilityPublished Updated

CVE-2025-38003: linux-ibm, linux-intel-iotg, linux-oracle, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-38003· High

Not known to be exploited · fixed in 5.15.0-1084.87 : patch Linux kernel soon.

Data as of 3 Nov 2026, 18:13 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.15.0-1084.87, 5.15.0-1085.91, 5.15.0-1088.94

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 5.15.0-1084.87 (linux-ibm package, linux-raspi package) or 5.15.0-1085.91 (linux-intel-iotg package) or 5.15.0-1088.94 (linux-oracle package).

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1084.87
Fixed in
  • 5.15.0-1084.87
Ubuntu 22.04 LTSlinux-intel-iotgpkg:deb/ubuntu/linux-intel-iotg?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1085.91
Fixed in
  • 5.15.0-1085.91
Ubuntu 22.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1088.94
Fixed in
  • 5.15.0-1088.94
Ubuntu 22.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1084.87
Fixed in
  • 5.15.0-1084.87

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately by updating to the fixed kernel versions 5.15.0-1084.87, 5.15.0-1085.91, or 5.15.0-1088.94 depending on the platform. After updating, a system reboot is required to apply the changes. Due to ABI changes, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-7704-3 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting various subsystems including cryptographic APIs, device drivers, media, networking, file systems, and others. These flaws could potentially allow an attacker to compromise the system. The issues are addressed in updated Linux kernel packages for several platforms including IBM cloud systems, Intel IoT platforms, Oracle Cloud systems, and Raspberry Pi systems. Users must update to fixed versions and reboot to apply the patches. Due to ABI changes, recompilation of third-party kernel modules is required after updating.

References

Community reviews

Loading reviews…