Skip to main content
CVE-2026-23060VulnerabilityPublished Updated

linux, linux-aws, linux-aws-6.17, linux-gcp, linux-gcp-6.17, linux-hwe-6.17, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-23060· High

Not known to be exploited · fixed in 6.17.0-1010.10~24.04.1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1010.10~24.04.1, 6.17.0-20.20~24.04.1, 6.17.0-20.20 +2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-20.20
Fixed in
  • 6.17.0-20.20
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1009.10
Fixed in
  • 6.17.0-1009.10
Ubuntu 24.04 LTSlinux-aws-6.17pkg:deb/ubuntu/linux-aws-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1010.10~24.04.1
Fixed in
  • 6.17.0-1010.10~24.04.1
Ubuntu 24.04 LTSlinux-gcp-6.17pkg:deb/ubuntu/linux-gcp-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1010.10~24.04.1
Fixed in
  • 6.17.0-1010.10~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions listed by Ubuntu (e.g., 6.17.0-1010.10~24.04.1, 6.17.0-20.20~24.04.1). After updating, a system reboot is required to apply the changes. Due to ABI changes, any third-party kernel modules must be recompiled and reinstalled. Follow the official Ubuntu security notice USN-8149-1 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting subsystems including the Cryptographic API, Netfilter, and network traffic control. These flaws could potentially allow an attacker to compromise the system. The issues affect various Linux kernel packages including linux-aws, linux-gcp, linux-hwe, and linux-realtime. Fixes have been released in updated kernel versions, and users are advised to apply these updates and reboot their systems. Due to ABI changes, recompilation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…