linux, linux-aws, linux-aws-6.17, linux-gcp, linux-gcp-6.17, linux-oracle, linux-oracle-6.17 vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Fixed in 6.17.0-1019.19~24.04.1 : patch Linux kernel soon.
Data as of 30 Jul 2026, 19:44 UTC
Rated by Threat Radar
- Patch
- Available – fixed in 6.17.0-1019.19~24.04.1, 6.17.0-1020.22~24.04.1, 6.17.0-1018.18~24.04.1 +4
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1018.18?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-aws-6.17pkg:deb/ubuntu/linux-aws-6.17@6.17.0-1019.19~24.04.1?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcp-6.17pkg:deb/ubuntu/linux-gcp-6.17@6.17.0-1020.22~24.04.1?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available as indicated by the presence of updated kernel versions that address these vulnerabilities. Users should apply the official Linux kernel updates corresponding to their distribution and kernel variant to remediate these issues. The affected versions are explicitly listed; upgrading to versions beyond these or applying vendor-provided patches will mitigate the risk. No additional vendor advisory content contradicts this guidance.
Description
Multiple security vulnerabilities were identified in the Linux kernel affecting various subsystems including ARM64 architecture, block layer, cryptographic API, network drivers, file systems, and networking protocols. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact several Linux kernel versions, particularly those prior to certain 6.17.x updates and specific earlier versions. This update addresses a broad range of flaws across many kernel components.
References
- ubuntu.com/security/notices/USN-8490-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-22984 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23272 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23278 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23392 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23427 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23428 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23450 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23455 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31402 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31418 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31436 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31448 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31478 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31607 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31635 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31637 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31649 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31657 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31659 (opens in a new tab)