Skip to main content
CVE-2024-57948VulnerabilityPublished Updated

linux, linux-aws, linux-gcp, linux-hwe-6.11, linux-lowlatency, linux-lowlatency-hwe-6.11, linux-oem-6.11

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.11.0-24.24~24.04.1 : update Linux kernel when convenient.

Data as of 29 Oct 2026, 22:33 UTC

Severity
Unrated

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.11.0-24.24~24.04.1, 6.11.0-1012.13~24.04.1, 6.11.0-1020.20

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu to 6.11.0-24.24~24.04.1 (linux-hwe-6.11 package) or 6.11.0-1012.13~24.04.1 (linux-lowlatency-hwe-6.11 package) or 6.11.0-1020.20 (linux-oem-6.11 package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-hwe-6.11pkg:deb/ubuntu/linux-hwe-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-24.24~24.04.1
Fixed in
  • 6.11.0-24.24~24.04.1
Ubuntu 24.04 LTSlinux-lowlatency-hwe-6.11pkg:deb/ubuntu/linux-lowlatency-hwe-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1012.13~24.04.1
Fixed in
  • 6.11.0-1012.13~24.04.1
Ubuntu 24.04 LTSlinux-oem-6.11pkg:deb/ubuntu/linux-oem-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1020.20
Fixed in
  • 6.11.0-1020.20

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems: - GPIO subsystem; - GPU drivers; - IRQ chip drivers; - Network drivers; - Mellanox network drivers; - x86 platform drivers; - i.MX PM domains; - SCSI subsystem; - USB Serial drivers; - AFS file system; - GFS2 file system; - File systems infrastructure; - Proc file system; - SMB network file system; - Timer subsystem; - Kernel CPU control infrastructure; - Memory management; - Networking core; - Ethtool driver; - IEEE 802.15.4 subsystem; - Open vSwitch; - Network traffic control; - VMware vSockets driver; (CVE-2025-21685, CVE-2025-21684, CVE-2025-21756, CVE-2025-21670, CVE-2024-57949, CVE-2025-21677, CVE-2025-21680, CVE-2025-21703, CVE-2024-57952, CVE-2025-21674, CVE-2025-21701, CVE-2025-21691, CVE-2025-21689, CVE-2025-21668, CVE-2025-21665, CVE-2025-21683, CVE-2025-21675, CVE-2025-21672, CVE-2024-57948, CVE-2025-21669, CVE-2025-21673, CVE-2025-21692, CVE-2025-21699, CVE-2025-21702, CVE-2025-21682, CVE-2025-21690, CVE-2025-21681, CVE-2025-21695, CVE-2025-21696, CVE-2025-21700, CVE-2025-21678, CVE-2025-21676, CVE-2024-57950, CVE-2025-21666, CVE-2025-21694, CVE-2025-21693, CVE-2025-21993, CVE-2024-57951, CVE-2025-21697, CVE-2025-21667)

References

Community reviews

Loading reviews…