Skip to main content
VulnerabilityPublished Updated

CVE-2025-37838: linux-nvidia-6.8, linux-oracle, linux-oracle-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1042.45~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:11 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1042.45~22.04.1, 6.8.0-1039.40~22.04.1, 6.8.0-1039.40

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1042.45~22.04.1 (linux-nvidia-6.8 package) or 6.8.0-1039.40~22.04.1 (linux-oracle-6.8 package) or 6.8.0-1039.40 (linux-oracle package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.40
Fixed in
  • 6.8.0-1039.40
Ubuntu 22.04 LTSlinux-nvidia-6.8pkg:deb/ubuntu/linux-nvidia-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1042.45~22.04.1
Fixed in
  • 6.8.0-1042.45~22.04.1
Ubuntu 22.04 LTSlinux-oracle-6.8pkg:deb/ubuntu/linux-oracle-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1039.40~22.04.1
Fixed in
  • 6.8.0-1039.40~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released fixed kernel versions (6.8.0-1039.40, 6.8.0-1042.45~22.04.1, and 6.8.0-1039.40~22.04.1) addressing these vulnerabilities. Users must update their systems and reboot to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules are required after updating. Follow the official Ubuntu security notice USN-7861-3 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel, including a flaw known as VMSCAPE that involves insufficient branch predictor isolation between a guest VM and a userspace hypervisor on certain processors. This could allow an attacker within a guest VM to potentially expose sensitive information from the host OS. Additional issues affect the HSI, Bluetooth, and Timer subsystems. These vulnerabilities could be exploited to compromise system security. Fixes have been released and are available in updated Linux kernel packages.

References

Community reviews

Loading reviews…