Skip to main content
VulnerabilityPublished Updated

CVE-2024-58090: linux-nvidia, linux-nvidia-6.8, linux-nvidia-lowlatency vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.8.0-1039.42~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:36 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1039.42~22.04.1, 6.8.0-1039.42, 6.8.0-1039.42.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1039.42~22.04.1 (linux-nvidia-6.8 package) or 6.8.0-1039.42 (linux-nvidia package) or 6.8.0-1039.42.1 (linux-nvidia-lowlatency package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.42
Fixed in
  • 6.8.0-1039.42
Ubuntu 24.04 LTSlinux-nvidia-lowlatencypkg:deb/ubuntu/linux-nvidia-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.42.1
Fixed in
  • 6.8.0-1039.42.1
Ubuntu 22.04 LTSlinux-nvidia-6.8pkg:deb/ubuntu/linux-nvidia-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1039.42~22.04.1
Fixed in
  • 6.8.0-1039.42~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security updates provided by Ubuntu for linux-nvidia-6.8 packages to versions 6.8.0-1039.42~22.04.1, 6.8.0-1039.42, or 6.8.0-1039.42.1 as appropriate. After updating, reboot the system to activate the fixes. Due to an ABI change, recompile and reinstall all third-party kernel modules. Follow the vendor advisory USN-7765-1 for detailed instructions. No other mitigation actions are specified or required.

Description

Multiple security vulnerabilities were discovered in the Linux kernel used in NVIDIA systems, affecting numerous subsystems including architectures (ARM32, ARM64, x86), GPU drivers, network drivers, memory management, and others. These flaws could potentially allow an attacker to compromise the system. Updates correcting these issues are available for linux-nvidia-6.8 and related packages. Users must apply the updates and reboot to ensure protection. Due to an ABI change, recompilation of third-party kernel modules is required after updating.

References

Community reviews

Loading reviews…