CVE-2025-21709: linux-nvidia, linux-nvidia-6.8, linux-nvidia-lowlatency vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · fixed in 6.8.0-1059.62~22.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 05:11 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1059.62~22.04.1, 6.8.0-1059.62, 6.8.0-1059.62.1
Exploitation evidence
Disclosed: evidence found.
CVE published 23 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.0-1059.62~22.04.1 (linux-nvidia-6.8 package) or 6.8.0-1059.62 (linux-nvidia package) or 6.8.0-1059.62.1 (linux-nvidia-lowlatency package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-nvidia-lowlatencypkg:deb/ubuntu/linux-nvidia-lowlatency?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinux-nvidia-6.8pkg:deb/ubuntu/linux-nvidia-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update to linux-nvidia kernel versions 6.8.0-1059.62~22.04.1, 6.8.0-1059.62, or 6.8.0-1059.62.1 or later. After updating, a system reboot is required to apply the fixes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow vendor guidance for updating and recompiling modules. No additional mitigation actions are indicated beyond applying the official update.
Description
Multiple security vulnerabilities affecting the Linux kernel for NVIDIA systems and related subsystems were discovered, including issues in AMD processors related to speculative execution, resource isolation, and entropy handling. These vulnerabilities could allow local attackers to expose sensitive information, escalate privileges, or influence cryptographic operations. The update addresses numerous flaws across a wide range of kernel subsystems and drivers. Fixed versions are available and users are advised to update and reboot their systems.
References
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21709 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22116 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38426 (opens in a new tab)
- ubuntu.com/security/CVE-2025-39764 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40135 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40150 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54505 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2025-62626 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68175 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68334 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71152 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71161 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71203 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71221 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71269 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71287 (opens in a new tab)