Skip to main content
VulnerabilityPublished Updated

CVE-2025-54518: linux-nvidia, linux-nvidia-7.0 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-54518· High 7.3

Not known to be exploited · CVSS 7.3 High · fixed in 7.0.0-1016.16~24.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 03:30 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.0-1016.16~24.04.1, 7.0.0-1016.16
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu to 7.0.0-1016.16~24.04.1 (linux-nvidia-7.0 package) or 7.0.0-1016.16 (linux-nvidia package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1016.16
Fixed in
  • 7.0.0-1016.16
Ubuntu 24.04 LTSlinux-nvidia-7.0pkg:deb/ubuntu/linux-nvidia-7.0?arch=source&distro=nobleOther threatsAffected
  • <7.0.0-1016.16~24.04.1
Fixed in
  • 7.0.0-1016.16~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vendor advisory (Ubuntu USN-8663-1) provides updated linux-nvidia-7.0 kernel packages (versions 7.0.0-1016.16 and 7.0.0-1016.16~24.04.1) that fix these vulnerabilities. After applying the update, a system reboot is required. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow the vendor's update instructions to ensure full remediation.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for NVIDIA systems, including a critical issue affecting AMD Zen 2 processors where improper isolation of shared resources in the operation cache could allow a local attacker to corrupt instructions executed at higher privilege levels, leading to privilege escalation. The update addresses numerous flaws across a wide range of kernel subsystems and drivers. Fixed versions have been released for linux-nvidia-7.0 packages.

References

Community reviews

Loading reviews…