Skip to main content
VulnerabilityPublished

linux-nvidia, linux-nvidia-7.0 vulnerabilities

Affects Linux kernelSource GCVE Database

0

Mentioned vulnerabilities

Fixed in 7.0.0-1015.15~24.04.1 : patch Linux kernel soon.

Data as of 30 Jul 2026, 07:38 UTC

Severity
High

Rated by Threat Radar

Patch
Available – fixed in 7.0.0-1015.15~24.04.1, 7.0.0-1015.15

What to do

Upgrade the Ubuntu to 7.0.0-1015.15~24.04.1 (linux-nvidia-7.0 package) or 7.0.0-1015.15 (linux-nvidia package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1015.15?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1015.15
Fixed in
  • 7.0.0-1015.15
Ubuntu 24.04 LTSlinux-nvidia-7.0pkg:deb/ubuntu/linux-nvidia-7.0@7.0.0-1015.15~24.04.1?arch=source&distro=nobleOther threatsAffected
  • <7.0.0-1015.15~24.04.1
Fixed in
  • 7.0.0-1015.15~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available as indicated by the presence of updated versions beyond 7.0.0-1015.15. Users should upgrade to versions at or above 7.0.0-1015.15 to remediate these vulnerabilities. Since this is not a cloud service, remediation depends on applying the vendor's updates. Patch status is confirmed by the affectedVersions data indicating that versions before 7.0.0-1015.15 are vulnerable.

Description

Multiple security vulnerabilities were identified in the Linux kernel components used by the linux-nvidia-7.0 package, specifically affecting the ARM64 architecture and the Arm Firmware Framework for ARMv8-A (FFA). These flaws could potentially allow an attacker to compromise the system. The vulnerabilities are tracked under CVE-2026-53354 and CVE-2026-64520. Affected versions include several specific builds prior to 7.0.0-1015.15. No CVSS score is available for these issues.

References

Community reviews

Loading reviews…