CVE-2025-54518: linux-nvidia-bos vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 7.0.0-2016.16 soon.
Data as of 28 Oct 2026, 03:30 UTC
- Patch
- Available – fixed in 7.0.0-2016.16
CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia-bos package to 7.0.0-2016.16.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-nvidia-bospkg:deb/ubuntu/linux-nvidia-bos?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update to linux-nvidia-bos version 7.0.0-2016.16 or later to address these vulnerabilities. After applying the update, a system reboot is required to complete remediation. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8664-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel used in NVIDIA BaseOS systems, including a critical issue affecting AMD Zen 2 processors where improper isolation of shared resources in the operation cache could allow a local attacker to corrupt instructions executed at a higher privilege level, leading to privilege escalation. The update addresses numerous flaws across a wide range of kernel subsystems and drivers. Users should update to fixed versions to mitigate these issues.
References
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43490 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43492 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43495 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43496 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43497 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43498 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43502 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45834 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45835 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45836 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45837 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45838 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45839 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45840 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45841 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45842 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45843 (opens in a new tab)
- ubuntu.com/security/CVE-2026-45844 (opens in a new tab)