CVE-2025-10263: linux-raspi vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 7.0.0-1019.19 as a priority.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1019.19
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi package to 7.0.0-1019.19.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing these vulnerabilities is available in Linux kernel version 7.0.0-1019.19 and later. Users and administrators should apply this update promptly. Refer to the official Ubuntu security notice USN-8726-2 for patch details: https://ubuntu.com/security/notices/USN-8726-2
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures, including ARM64, ARM32, RISC-V, x86, and many drivers and filesystems. One notable issue (CVE-2025-10263) involves some ARM processors completing a broadcast TLB invalidation before memory writes through the invalidated translation are globally observed, potentially allowing local attackers to write to memory after permissions were revoked, bypassing memory protections or escalating privileges. These flaws could be exploited to compromise system security. A patch fixing these vulnerabilities is available.
References
- ubuntu.com/security/notices/USN-8726-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-10263 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52908 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52909 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52910 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52917 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52929 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52930 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52935 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52938 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52939 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52940 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52942 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52947 (opens in a new tab)
- ubuntu.com/security/CVE-2026-52948 (opens in a new tab)
- ubuntu.com/security/CVE-2026-53132 (opens in a new tab)
- ubuntu.com/security/CVE-2026-53133 (opens in a new tab)
- ubuntu.com/security/CVE-2026-53134 (opens in a new tab)
- ubuntu.com/security/CVE-2026-53135 (opens in a new tab)
- ubuntu.com/security/CVE-2026-53136 (opens in a new tab)