CVE-2025-21709: linux-raspi, linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · fixed in 6.8.0-1061.65 : patch Linux kernel soon.
Data as of 28 Oct 2026, 05:11 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1061.65, 6.8.0-2050.52
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.0-1061.65 (linux-raspi package) or 6.8.0-2050.52 (linux-raspi-realtime package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Update the linux-raspi and linux-raspi-realtime kernel packages to versions 6.8.0-1061.65 or 6.8.0-2050.52 or later as provided by the vendor. After updating, reboot the system to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to maintain compatibility. Follow the vendor's update instructions carefully to ensure full remediation.
Description
Multiple security vulnerabilities affecting the Linux kernel for Raspberry Pi systems were addressed in this update. These include speculative execution flaws in AMD processors that could expose sensitive information, issues in AMD Zen 2 processors that might allow privilege escalation, and entropy handling flaws in AMD Zen 5 processors affecting randomness quality. Additionally, numerous security issues across a wide range of Linux kernel subsystems and drivers were fixed. These vulnerabilities could potentially allow local attackers to compromise system integrity or confidentiality. The update requires a system reboot and recompilation of third-party kernel modules due to ABI changes.
References
- ubuntu.com/security/notices/USN-8665-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21709 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22116 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38426 (opens in a new tab)
- ubuntu.com/security/CVE-2025-39764 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40135 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40150 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54505 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2025-62626 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68175 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68334 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71152 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71161 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71203 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71221 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71269 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71287 (opens in a new tab)