CVE-2026-45357: LiquidJS has a memory and render limit bypass via unbounded width padding in `date` filter (strftime)
Affects liquidjsSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 10.26.0 soon.
Data as of 28 Oct 2026, 17:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.26.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade liquidjs to 10.26.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmliquidjs | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in LiquidJS version 10.26.0. Operators should upgrade to this version to address the vulnerability. The fix includes capping the padding width in the strftime implementation and modifying the padding function to properly charge the context's memory limit and use efficient string repetition. Until upgrading, no effective mitigation exists because the vulnerability bypasses the engine's memory and render limits.
Description
LiquidJS versions prior to 10.26.0 contain a vulnerability in the `date` filter's strftime implementation that allows unbounded width padding. This flaw bypasses the engine's memory and render limits by passing unchecked large width specifiers to a padding function, causing excessive memory allocation and CPU usage. An attacker can exploit this by supplying a crafted date format string, leading to denial of service via high resource consumption or process crash due to out-of-memory conditions. The vulnerability is fixed in version 10.26.0.
References
- github.com/harttle/liquidjs/security/advisories/GHSA-hh27-hf48-9f5q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-45357 (opens in a new tab)
- github.com/harttle/liquidjs/commit/3129d46dc95efa357b00e5a57ee1af80a13d72ed (opens in a new tab)
- github.com/harttle/liquidjs (opens in a new tab)
- github.com/harttle/liquidjs/blob/v10.26.0/CHANGELOG.md (opens in a new tab)
- github.com/harttle/liquidjs/releases/tag/v10.26.0 (opens in a new tab)