CVE-2026-114612: LiteLLM · Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key
Affects litellmSource GCVE Database
Not known to be exploited · CVSS 9.9 Critical : upgrade to 1.100.4 as a priority.
Data as of 27 Oct 2026, 16:27 UTC
- Patch
- Available – fixed in 1.100.4, 1.101.3, 1.102.2 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIlitellm | Affected
| Fixed in
|
| PyPIlitellm | Affected
| Fixed in
|
| PyPIlitellm | Affected
| Fixed in
|
| PyPIlitellm | Affected
| Fixed in
|
| PyPIlitellm | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
### Summary An authenticated user with `internal_user` privileges can escalate to `proxy_admin` and achieve remote code execution. The proxy uses one encryption key for two purposes: sealing secrets at rest and minting session tokens. An attacker exploits this by requesting a new API key with a crafted metadata field containing a forged admin credential as the "secret" value. The proxy encrypts and returns this payload. When this value is then presented as a bearer token, the proxy decrypts it, trusts the forged admin identity, and grants full administrative access, including the ability to execute arbitrary commands via the MCP stdio endpoint. ### Affected versions Versions later than 1.91.0 are exploitable in the default configuration. Versions 1.87.0 through 1.90.x are exploitable only if `EXPERIMENTAL_UI_LOGIN=true` was explicitly set. ### Mitigation Upgrade to a patched version as soon as possible. If you cannot upgrade immediately, set `EXPERIMENTAL_UI_LOGIN=false`. This disables the vulnerable authentication path but also breaks CLI SSO and Claude Code gateway login. ### Impact An internal user can escalate to proxy admin and execute arbitrary commands on the host. **Discovery Credit:** Hoa X. Nguyen (OPSWAT Unit 515)
References
- github.com/BerriAI/litellm/security/advisories/GHSA-7hp6-4w63-5g45 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114612 (opens in a new tab)
- github.com/BerriAI/litellm/commit/1d5fdc87fed66b49e1df8cf7d708ad93249eb7d0 (opens in a new tab)
- github.com/BerriAI/litellm/commit/9161d7f9d6073603ba61ee4aa5e2c0ef5b37a81b (opens in a new tab)
- github.com/BerriAI/litellm/commit/9fa1a641119dd0d4fe43e93622eae5f482ceb63f (opens in a new tab)
- github.com/BerriAI/litellm/commit/a80eacacee118fbed54e3d98f239d17a63fac818 (opens in a new tab)
- github.com/BerriAI/litellm/commit/f7cd90f09e9716652b38daec9f0640cdf49d582b (opens in a new tab)
- github.com/BerriAI/litellm (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.100.4 (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.101.3 (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.102.2 (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.103.1 (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.104.0-rc.2 (opens in a new tab)