Skip to main content
VulnerabilityPublished

LiteLLM Vulnerable to Reflected XSS

Affects litellmSource GCVE Database

0

CVSS 6.8 Medium : upgrade to 1.85.0 when convenient.

Data as of 27 Oct 2026, 16:27 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.85.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

What to do

Upgrade litellm to 1.85.0.

Affected software

ProductAffectedFixed in
PyPIlitellmAffected
  • >=1.65.5 <1.85.0
Fixed in
  • 1.85.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Summary The `/sso/debug/callback` endpoint reflected identity-provider-controlled fields into an inline `<script>` block via `json.dumps`, which escapes JSON string syntax but not HTML context characters such as `</script>`. An IdP-returned string field containing `</script>` (for example a user-editable display name) closed the script block and executed attacker JavaScript in the proxy's origin. ### Impact Reflected XSS on the LiteLLM proxy origin. The route required no authentication, so an attacker with an account on the configured IdP whose claims pass such strings through verbatim could complete the SSO flow themselves and deliver the resulting callback URL to a logged-in proxy admin. Scripts executing in the proxy origin can read the dashboard session cookie and act with the victim's privileges, up to full admin account takeover.

References

Community reviews

Loading reviews…