LM Studio before 0.4.22+1 contains a path traversal vulnerability in the model downloader's resolveDownloadRequest
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 0.4.22+1 soon.
Data as of 30 Oct 2026, 20:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Patch
- Available – fixed in 0.4.22+1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade LM Studio to 0.4.22+1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Element LabsLM Studio | Affected
| Fixed in
|
AI-suggested
Since the vulnerability affects versions before 0.4.22+1, upgrading to version 0.4.22+1 or later is implied as the remediation. Users should verify with the vendor or official sources for an official fix and apply it promptly.
Description
LM Studio versions before 0.4.22+1 have a path traversal vulnerability in the model downloader's resolveDownloadRequest function. This flaw allows attackers to write files outside the intended models directory by using backslash-separated traversal filenames. Exploitation can lead to planting malicious files such as plugin manifest.json, install-state.json, and mcp-bridge-config.json, which execute an attacker-supplied Python payload on every application launch.