Skip to main content
VulnerabilityPublished Updated

CVE-2024-49766: Recon ng · Werkzeug safe_join not safe on Windows

Affects recon-ngSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 5.1.2_2 when convenient.

Data as of 1 Nov 2026, 22:57 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.32.0_1, 3.1.1, 5.0.18_1 +1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Homebrewlocustpkg:brew/locustOther threatsAffected
  • >=2.2.1 <2.32.0_1
Fixed in
  • 2.32.0_1
Homebrewmapproxypkg:brew/mapproxyOther threatsAffected
  • >=2.1.1 <3.1.1
Fixed in
  • 3.1.1
Homebrewmotopkg:brew/motoOther threatsAffected
  • >=2.0.2 <5.0.18_1
Fixed in
  • 5.0.18_1
Homebrewrecon-ngpkg:brew/recon-ngOther threatsAffected
  • >=5.1.1_1 <5.1.2_2
Fixed in
  • 5.1.2_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available to address this vulnerability. Users should upgrade to a fixed version of the affected software or ensure their Python environment is version 3.11 or later on Windows. Applying the official patch or upgrading Python will mitigate the risk. No additional vendor advisory details contradict this guidance.

Description

CVE-2024-49766 is a vulnerability affecting Mapproxy on Windows systems running Python versions earlier than 3.11. It stems from Werkzeug's safe_join() function incorrectly handling UNC paths as absolute due to reliance on os.path.isabs() in these Python versions. This flaw can lead to unsafe path joins and potentially unintended data access. Systems using Python 3.11 or later, or non-Windows platforms, are not affected. A patch is available to remediate this issue.

References

Community reviews

Loading reviews…