CVE-2026-115355: Mistune · Path Traversal and XSS in Include directive
Affects recon-ngSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 5.1.2_4 soon.
Data as of 27 Oct 2026, 06:44 UTC
- Patch
- Available – fixed in 5.1.2_4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade recon-ng to 5.1.2_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewrecon-ngpkg:brew/recon-ngOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in recon-ng version 5.1.2_4 that fixes the path traversal and XSS issues. Users should upgrade to this version or later. Since the Include plugin must be explicitly enabled, disabling or not enabling this plugin also mitigates the risk. No additional vendor advisories indicate other mitigations or that the issue is already mitigated.
Description
CVE-2026-115355 is a vulnerability in the Include directive of the Mistune markdown parser used in recon-ng. It allows path traversal via '../' sequences to read arbitrary files outside the intended source directory. Additionally, error messages and included file contents are rendered without HTML escaping, enabling cross-site scripting (XSS) even when escaping is enabled. The Include plugin must be explicitly enabled to be exploitable. A fix is available in version 5.1.2_4.
References
- github.com/lepture/mistune/security/advisories/GHSA-h7ww-273w-6cm8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-115355 (opens in a new tab)
- github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993 (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/lepture/mistune/releases/tag/v3.3.0 (opens in a new tab)
- vulncheck.com/advisories/mistune-before-3.3.0-path-traversal-and-xss-via-include-directive (opens in a new tab)