CVE-2026-2950: lodash vulnerable to prototype pollution via array-path bypass in `_.unset`, `_.omit`, and `_.pullAt
Affects lodashSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.18.1 when convenient.
Data as of 3 Nov 2026, 16:14 UTC
- Patch
- Available – fixed in 4.18.1, 4.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade lodash and lodash-es and lodash-amd to 4.18.1; lodash.unset and lodash.omit to 4.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmlodash | Affected
| Fixed in
|
| npmlodash-es | Affected
| Fixed in
|
| npmlodash-amd | Affected
| Fixed in
|
| npmlodash.unset | Affected
| Fixed in
|
| npmlodash.omit | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade lodash and related packages to versions 4.18.1 or later (for lodash, lodash-es, lodash-amd) and 4.18.0 or later (for lodash.unset and lodash.omit). No other workarounds are available. Applying these patches fully mitigates the vulnerability.
Description
Lodash versions prior to 4.18.1 (and some standalone packages prior to 4.18.0) are vulnerable to prototype pollution via the _.unset, _.omit, and _.pullAt functions. An attacker can bypass previous fixes by using array-wrapped path segments to delete properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype. This vulnerability allows deletion of prototype properties but does not enable overwriting their original behavior. The issue is patched in lodash 4.18.1 and related packages 4.18.0 and later.
References
- github.com/lodash/lodash/security/advisories/GHSA-f23m-r3pf-42rh (opens in a new tab)
- github.com/lodash/lodash/security/advisories/GHSA-xxjr-mmjv-4gpg (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-2950 (opens in a new tab)
- github.com/lodash/lodash/commit/4f0e376589e1889e8993e212a5c9041112ad178e (opens in a new tab)
- github.com/lodash/lodash/commit/87e6676934f7b4450fad68c35f0325ba165b48f8 (opens in a new tab)
- github.com/lodash/lodash/commit/bbcf0036d27ef936f175bf26e73e247994d8e1e4 (opens in a new tab)
- github.com/lodash/lodash/commit/db27b6bb14b12a1451b20edf87dfe307b87a337d (opens in a new tab)
- github.com/lodash/lodash/commit/fe8d32eda854377349a4f922ab7655c8e5df9a0b (opens in a new tab)
- cna.openjsf.org/security-advisories.html (opens in a new tab)
- github.com/lodash/lodash (opens in a new tab)
- github.com/lodash/lodash/releases/tag/4.18.1 (opens in a new tab)