Skip to main content
VulnerabilityPublished

github.com/canonical/lxd · LXD has restricted project bypass leading to arbitrary command execution

Affects github.com/canonical/lxdSource GCVE Database

0

CVSS 9.9 Critical : upgrade to 0.0.0-20260630083100-c5184be310b1 as a priority.

Data as of 6 Nov 2026, 20:27 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.0.0-20260630083100-c5184be310b1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

What to do

Upgrade github.com/canonical/lxd to 0.0.0-20260630083100-c5184be310b1.

Affected software

ProductAffectedFixed in
Gogithub.com/canonical/lxdAffected
  • <0.0.0-20260630083100-c5184be310b1
Fixed in
  • 0.0.0-20260630083100-c5184be310b1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 0.0.0-20260630083100-c5184be310b1. Users should upgrade to this fixed version to remediate the vulnerability. No other mitigation is indicated or required as the patch fully addresses the issue.

Description

A vulnerability in LXD (Incus) allows bypassing project restrictions that are intended to block low-level container operations. Specifically, instance snapshots ignore the 'restricted.containers.lowlevel=block' setting, enabling attackers to abuse low-level hooks like 'raw.lxc' and 'raw.qemu' to execute arbitrary commands on the host with root privileges. This can be exploited by crafting a malicious snapshot locally and restoring it in a restricted project on a remote server, resulting in full command execution on the Incus server.

References

Community reviews

Loading reviews…