CVE-2026-12411: github.com/canonical/lxd · lxd allows Cross-guest volume hijack via DevLXD device patch
Affects github.com/canonical/lxdSource GCVE Database
Not known to be exploited · CVSS 8.4 High : upgrade to 0.0.0-20260626085133-7cb96ac80a6d soon.
Data as of 5 Nov 2026, 18:50 UTC
- Patch
- Available – fixed in 0.0.0-20260626085133-7cb96ac80a6d
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade github.com/canonical/lxd to 0.0.0-20260626085133-7cb96ac80a6d.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/canonical/lxd | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in version 0.0.0-20260626085133-7cb96ac80a6d. Users should upgrade to this fixed version or later to remediate the vulnerability. No other mitigations are indicated by the vendor advisory.
Description
A vulnerability in LXD allows a guest container to mount and access another guest's custom storage volume without ownership. This occurs because the device-update path that attaches volumes to containers does not verify volume ownership, enabling tenants with the 'security.devlxd.management.volumes' permission to hijack volumes from other tenants within the same project. The flaw affects LXD versions prior to the fixed commit 0.0.0-20260626085133-7cb96ac80a6d and has a high severity CVSS score of 8.4.
References
- github.com/canonical/lxd/security/advisories/GHSA-hhf9-qw4v-72xp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-12411 (opens in a new tab)
- github.com/canonical/lxd/pull/18585 (opens in a new tab)
- github.com/canonical/lxd/commit/752e25cfb849a349ff08939ce02747ef4d4e69cc (opens in a new tab)
- github.com/canonical/lxd (opens in a new tab)