Skip to main content
VulnerabilityPublished Updated

CVE-2025-54288: github.com/canonical/lxd · Canonical LXD Source Container Identification Vulnerability via cmdline Spoofing in devLXD Server

Affects github.com/canonical/lxdSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54288· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 5.21.4 when convenient.

Data as of 4 Nov 2026, 18:22 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.21.4, 6.5, 0.0.0-20250827065555-0494f5d47e41
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade github.com/canonical/lxd to 5.21.4; github.com/canonical/lxd to 6.5; github.com/canonical/lxd to 0.0.0-20250827065555-0494f5d47e41.

Affected software

ProductAffectedFixed in
Gogithub.com/canonical/lxdAffected
  • >=4.0 <5.21.4
Fixed in
  • 5.21.4
Gogithub.com/canonical/lxdAffected
  • >=6.0 <6.5
Fixed in
  • 6.5
Gogithub.com/canonical/lxdAffected
  • >=0.0.0-20200331193331-03aab09f5b5c <0.0.0-20250827065555-0494f5d47e41
Fixed in
  • 0.0.0-20250827065555-0494f5d47e41

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Patches are available and should be applied: LXD 5.21.4 and LXD 6.5 contain fixes that restrict cmdline-based identification to processes sharing the same PID namespace as the LXD daemon, preventing spoofing. Users should upgrade to these fixed versions. No additional action is required if running these patched versions.

Description

CVE-2025-54288 is a vulnerability in Canonical LXD's devLXD server where the source container identification relies on process command line information. This allows attackers with root privileges inside a container to spoof process names and impersonate other containers, thereby accessing their metadata, configuration, and device information. The issue arises because the identification function trusts cmdline data without sufficiently verifying PID namespaces. Fixes are available in LXD versions 5.21.4 and 6.5.

References

Community reviews

Loading reviews…