Skip to main content
VulnerabilityPublished Updated

CVE-2025-54286: github.com/canonical/lxd · Canonical LXD CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI

Affects github.com/canonical/lxdSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54286· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.0.5 soon.

Data as of 4 Nov 2026, 18:23 UTC

CVSS 4.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.0.5, 5.21.4, 6.5 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Gogithub.com/canonical/lxdAffected
  • >=5.0 <5.0.5
Fixed in
  • 5.0.5
Gogithub.com/canonical/lxdAffected
  • >=5.1 <5.21.4
Fixed in
  • 5.21.4
Gogithub.com/canonical/lxdAffected
  • >=6.0 <6.5
Fixed in
  • 6.5
Gogithub.com/canonical/lxdAffected
  • >=0.0.0-20220401034332-1e1349e3cbf3 <0.0.0-20250827065555-0494f5d47e41
Fixed in
  • 0.0.0-20250827065555-0494f5d47e41

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and should be applied by upgrading to LXD versions 5.0.5, 5.21.4, or 6.5. The vendor's primary recommended mitigation is to enforce strict Content-Type validation on API endpoints, accepting only application/json requests, which blocks CSRF attacks using HTML form submissions. Proper CORS settings prevent client certificates from being sent with cross-origin fetch API requests, further mitigating the risk. Additional mitigations such as CSRF tokens or Origin/Referer header validation could be implemented but may cause compatibility issues with other API clients like the LXD command-line tool.

Description

CVE-2025-54286 is a Cross-Site Request Forgery (CSRF) vulnerability in Canonical's LXD when using client certificate authentication with the LXD-UI. The vulnerability arises because client certificates bypass the SameSite cookie protections, and the LXD API accepts JSON payloads even when the Content-Type header is set to text/plain or application/x-www-form-urlencoded, allowing CSRF attacks via HTML form submissions. An attacker can exploit this by tricking an authenticated user into visiting a malicious website that automatically creates and starts arbitrary container instances. The vulnerability requires the victim to be authenticated with client certificates and have permissions to create instances. Fixes are available in LXD versions 5.0.5, 5.21.4, and 6.5.

References

Community reviews

Loading reviews…