CVE-2025-54293: Instance Log File Retrieval Function · Canonical LXD Path Traversal Vulnerability
Affects github.com/canonical/lxdSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 5.21.4 soon.
Data as of 4 Nov 2026, 18:22 UTC
- Patch
- Available – fixed in 5.21.4, 6.5, 0.0.0-20250224180022-ec09b24179f3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade github.com/canonical/lxd to 5.21.4; github.com/canonical/lxd to 6.5; github.com/canonical/lxd to 0.0.0-20250224180022-ec09b24179f3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/canonical/lxd | Affected
| Fixed in
|
| Gogithub.com/canonical/lxd | Affected
| Fixed in
|
| Gogithub.com/canonical/lxd | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in LXD versions 5.21.4, 6.5, and 0.0.0-20250224180022-ec09b24179f3 and later. Users should upgrade to these or later versions to remediate the vulnerability. Since the fix was applied as part of a code improvement PR, no separate security patch exists for LXD 5.0 and earlier versions. Environments running vulnerable versions should plan an upgrade. No additional mitigations are specified by the vendor advisory.
Description
A path traversal vulnerability exists in the validLogFileName function of the LXD 5.0 LTS series, allowing attackers with access to LXD-UI to read arbitrary files on the LXD host by exploiting insufficient validation of log file names. The issue also affects the validExecOutputFileName function, enabling attackers with command execution privileges inside containers to create symbolic links and access host files. This vulnerability was fixed as a side effect in LXD 5.21.4 and later versions. The flaw could lead to disclosure of sensitive host configuration files, LXD database files, and data from other instances.