Skip to main content
VulnerabilityPublished

CVE-2026-119280: MariaDB Connector/J · XA recover() trusted server-supplied gtrid and bqual lengths

Affects org.mariadb.jdbc:mariadb-java-clientSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119280· Low 3.7

Not known to be exploited · CVSS 3.7 Low : upgrade to 3.3.7 when convenient.

Data as of 31 Oct 2026, 02:06 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.13.7
Patch
Available – fixed in 3.3.7, 3.4.5, 3.5.11
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade org.mariadb.jdbc:mariadb-java-client to 3.3.7; org.mariadb.jdbc:mariadb-java-client to 3.4.5; org.mariadb.jdbc:mariadb-java-client to 3.5.11.

Affected software

ProductAffectedFixed in
Mavenorg.mariadb.jdbc:mariadb-java-clientAffected
  • >=3.0.0 <3.3.7
Fixed in
  • 3.3.7
Mavenorg.mariadb.jdbc:mariadb-java-clientAffected
  • >=3.4.0 <3.4.5
Fixed in
  • 3.4.5
Mavenorg.mariadb.jdbc:mariadb-java-clientAffected
  • >=3.5.0 <3.5.11
Fixed in
  • 3.5.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in MariaDB Connector/J versions 3.3.7, 3.4.5, and 3.5.11 that validates gtrid_length and bqual_length values before allocation and copying during XA recovery. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation is required if patched.

Description

MariaDB Connector/J versions 3.0.0 through before 3.3.7, 3.4.0 through before 3.4.5, and 3.5.0 through before 3.5.11 contain a vulnerability in the XAResource.recover() method. The method trusts server-supplied gtrid_length and bqual_length values without validating them against XA specification bounds, leading to potential large memory allocations or exceptions during XA recovery. This can cause availability issues such as crashes or denial of service. Exploitation requires control over the server side of the connection. Fixed versions are 3.3.7, 3.4.5, and 3.5.11.

References

Community reviews

Loading reviews…