CVE-2024-25641: cacti · Improper Input Validation
Affects cactiSource GCVE Database
Public exploit available (Metasploit, Exploit-DB) · CVSS 9.1 Critical : upgrade to 1.2.27 as a priority.
Data as of 31 Oct 2026, 01:21 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 9.1 |
|---|
- Patch
- Available – fixed in 1.2.27
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 13 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
1 Metasploit module · 1 Exploit-DB entry, 337 days after disclosure
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 95 days before disclosure
CVE published
on cve.org
, t = 0
First Exploit-DB entry (opens in a new tab)
Cacti 1.2.26 - Remote Code Execution (RCE) (Authenticated)
, 337 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cacti to 1.2.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in
|
AI-suggested
Upgrade Cacti to version 1.2.27 or later, where this vulnerability is patched. Applying this official fix eliminates the arbitrary file write and remote code execution risk. No additional mitigations are specified or required beyond updating to the fixed version.
Description
CVE-2024-25641 is a critical arbitrary file write vulnerability in Cacti versions prior to 1.2.27. It affects the "Package Import" feature, allowing authenticated users with "Import Templates" permission to write or overwrite files on the web server via path traversal in the import_package() function. This can lead to arbitrary PHP code execution. The issue is fixed in version 1.2.27.
References
- github.com/Cacti/cacti/security/advisories/GHSA-7cmj-g5qc-pj88 (opens in a new tab)
- github.com/Cacti/cacti/commit/eff35b0ff26cc27c82d7880469ed6d5e3bef6210 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/ (opens in a new tab)
- seclists.org/fulldisclosure/2024/May/6 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/09/msg00027.html (opens in a new tab)