Skip to main content
VulnerabilityPublished Updated

CVE-2024-31443: cacti · Cross-site Scripting

Affects cactiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.7 Medium : upgrade to 1.2.27 when convenient.

Data as of 31 Oct 2026, 01:21 UTC

CVSS 3.1 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.7
Patch
Available – fixed in 1.2.27
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cacti to 1.2.27.

Affected software

ProductAffectedFixed in
Cacti cactiAffected
  • <1.2.27
Fixed in
  • 1.2.27

AI-suggested

Upgrade Cacti to version 1.2.27 or later, where the vulnerability is patched. No additional mitigation steps are required as the official fix addresses the issue.

Description

CVE-2024-31443 is a cross-site scripting (XSS) vulnerability in Cacti prior to version 1.2.27. The issue arises from insufficient input validation in the form_save() function within data_queries.php, which leads to unsafe HTML concatenation in grow_right_pane_tree() in lib/html.php. This flaw allows an attacker with limited privileges to inject malicious scripts. The vulnerability is fixed in Cacti version 1.2.27.

References

Community reviews

Loading reviews…