CVE-2024-43364: cacti · Cross-site Scripting
Affects cactiSource GCVE Database
Not known to be exploited · CVSS 5.7 Medium : upgrade to 1.2.28 when convenient.
Data as of 30 Oct 2026, 00:25 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.7 |
|---|
- Patch
- Available – fixed in 1.2.28
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cacti to 1.2.28.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in
|
AI-suggested
Upgrade Cacti to version 1.2.28 or later, where this vulnerability has been fixed. There are no known workarounds. Applying the official patch is the only recommended mitigation.
Description
CVE-2024-43364 is a stored Cross-Site Scripting (XSS) vulnerability in the open source Cacti performance and fault management framework. The flaw exists in the handling of the 'title' parameter when creating external links via links.php. This parameter is not properly sanitized, allowing users with the privilege to create external links to inject malicious scripts that are stored in the database and later reflected in index.php. This vulnerability has been fixed in Cacti version 1.2.28. Users are advised to upgrade to this version to mitigate the issue. No known workarounds exist.