Skip to main content
VulnerabilityPublished Updated

CVE-2024-43362: cacti · Cross-site Scripting

Affects cactiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 1.2.28 soon.

Data as of 30 Oct 2026, 00:25 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.3
Patch
Available – fixed in 1.2.28
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade cacti to 1.2.28.

Affected software

ProductAffectedFixed in
Cacti cactiAffected
  • <1.2.28
Fixed in
  • 1.2.28

AI-suggested

Upgrade Cacti to version 1.2.28 or later to remediate this vulnerability. There are no known workarounds. Applying the official fix is the only recommended mitigation.

Description

CVE-2024-43362 is a stored Cross-Site Scripting (XSS) vulnerability in the open source Cacti performance and fault management framework. It arises from improper sanitization of the 'fileurl' parameter when users with privileges create external links. This parameter is embedded in HTML code and output without proper escaping, allowing stored XSS attacks. The issue is fixed in version 1.2.28. Users are advised to upgrade as no workarounds exist.

References

Community reviews

Loading reviews…