CVE-2024-31444: cacti · Cross-site Scripting
Affects cactiSource GCVE Database
Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.2.27 when convenient.
Data as of 31 Oct 2026, 01:21 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.6 |
|---|
- Patch
- Available – fixed in 1.2.27
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cacti to 1.2.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in
|
AI-suggested
Upgrade Cacti to version 1.2.27 or later, where this vulnerability is patched. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2024-31444 is a cross-site scripting (XSS) vulnerability in Cacti versions prior to 1.2.27. The issue arises from insufficient validation of data stored by the automation_tree_rules_form_save() function, which is later used in HTML concatenation in form_confirm(). This flaw allows injection of malicious scripts in the affected versions. The vulnerability is fixed in version 1.2.27.
References
- github.com/Cacti/cacti/security/advisories/GHSA-p4ch-7hjw-6m87 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/09/msg00027.html (opens in a new tab)