Skip to main content
VulnerabilityPublished Updated

CVE-2024-34340: cacti · Improper Authentication

Affects cactiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.2.27 as a priority.

Data as of 31 Oct 2026, 01:22 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.1
Patch
Available – fixed in 1.2.27
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cacti to 1.2.27.

Affected software

ProductAffectedFixed in
Cacti cactiAffected
  • <1.2.27
Fixed in
  • 1.2.27

AI-suggested

Upgrade Cacti to version 1.2.27 or later, where the vulnerability has been patched. No other mitigation is required as the official fix addresses the root cause of the authentication bypass.

Description

CVE-2024-34340 is a critical improper authentication vulnerability in Cacti versions prior to 1.2.27. The issue arises from a type juggling flaw in the password verification function, where an MD5 hash comparison uses a loose equality check. This allows authentication bypass under certain conditions. The vulnerability is patched in version 1.2.27.

References

Community reviews

Loading reviews…