Skip to main content
VulnerabilityPublished Updated

CVE-2026-7446: mcp-server-semgrep has a Command Injection issue

Affects mcp-server-semgrepSource GCVE Database

0
Authoritative record:CVE-2026-7446· Medium 6.9

Public exploit available · CVSS 6.9 Medium : upgrade to 1.0.1 as a priority.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mcp-server-semgrep to 1.0.1.

Affected software

ProductAffectedFixed in
npmmcp-server-semgrepAffected
  • <1.0.1
Fixed in
  • 1.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability was detected in VetCoders mcp-server-semgrep 1.0.0. This affects the function analyze_results/filter_results/export_results/compare_results/scan_directory/create_rule of the file src/index.ts of the component MCP Interface. The manipulation of the argument ID results in os command injection. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 1.0.1 is able to mitigate this issue. The patch is identified as 141335da044e53c3f5b315e0386e01238405b771. It is advisable to upgrade the affected component.

References

Community reviews

Loading reviews…