Skip to main content
VulnerabilityPublished Updated

CVE-2025-59420: Authlib · JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)

Affects mcpmSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.8.2 soon.

Data as of 1 Nov 2026, 22:57 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade mcpm to 2.8.2.

Affected software

ProductAffectedFixed in
Homebrewmcpmpkg:brew/mcpmOther threatsAffected
  • >=2.1.0 <2.8.2
Fixed in
  • 2.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Authlib to a fixed version that correctly enforces the RFC 7515 'must-understand' semantics for critical headers. Until patched, avoid relying on Authlib 1.6.3 for JWS verification in security-sensitive contexts involving critical headers. No vendor advisory content contradicts this guidance.

Description

Authlib version 1.6.3's JWS verification improperly accepts JSON Web Signatures (JWS) tokens containing unknown critical header parameters (`crit`), violating RFC 7515 requirements. This flaw allows tokens with critical headers that strict verifiers reject to be accepted, potentially causing authorization bypass in mixed-language environments. The vulnerability affects the `authlib.jose.JsonWebSignature.deserialize_compact(...)` API with default configuration. Exploitation can lead to split-brain verification scenarios, enabling replay or privilege escalation if critical security semantics are ignored.

References

Community reviews

Loading reviews…