Skip to main content
CVE-2026-109618VulnerabilityPublished

METTLER TOLEDO: PHP2Shell

Affects METTLER TOLEDOSource GCVE Database

0
Authoritative record:CVE-2026-109618· Critical 9.2

Exploited in the wild · KEV due 29 Oct 2026 · public exploit available (Exploit-DB) · fixed in 8.5.12 : patch METTLER TOLEDO now.

Data as of 28 Oct 2026, 23:13 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 8.5.12, 8.4.27, 8.3.36 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  3. Observed by OffSeq Mirage: evidence found.

    81 honeypot hits, first 43 hours after disclosure

Timeline

  1. CVE ID reserved

    by PHP Group

    , 9 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. First Exploit-DB entry (opens in a new tab)

    PHP2Shell (CVE-2026-109618) - PHP core versions after v5.4 - RCE

    , 1 day after disclosure

  4. First seen by OffSeq Mirage

    from 10 attacker networks; activity in United States, Monaco, Palestine, Brazil and 12 more

    , 43 hours after disclosure

  5. In Threat Radar

    record ingested

    , 5 days after disclosure

  6. , 5 days after disclosure

  7. , 7 days after disclosure

  8. KEV remediation due

    US federal deadline

    , 8 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PHP to 8.5.12, 8.4.27, 8.3.36 or 8.2.35.

Affected software

ProductAffectedFixed in
PHPphp-srcAffected
  • ≥ 8.5.*, < 8.5.12
Fixed in
  • 8.5.12
PHPphp-srcAffected
  • ≥ 8.4.*, < 8.4.27
Fixed in
  • 8.4.27
PHPphp-srcAffected
  • ≥ 8.3.*, < 8.3.36
Fixed in
  • 8.3.36
PHPphp-srcAffected
  • ≥ 8.2.*, < 8.2.35
Fixed in
  • 8.2.35

AI-suggested

Update the PHP package used by the Octo Image Server to version 8.2.35 as recommended by the vendor to eliminate the vulnerability. No indication of 'no action required' or 'already mitigated' is present, so remediation is advised.

Description

A critical vulnerability identified as CVE-2026-109618 affects the Octo Image Server component of METTLER TOLEDO products, specifically versions up to 5.0.10. The vulnerability involves a PHP2Shell issue, which could potentially allow unauthorized code execution. Although the product is typically deployed within internal networks and not exposed directly to the internet, updating the PHP package to version 8.2.35 is recommended to mitigate any potential risk and align with cybersecurity best practices.

References

Community reviews

Loading reviews…