Skip to main content
CVE-2026-110858VulnerabilityPublished

Mistral vibe: GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110858· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 3.0.3 as a priority.

Data as of 30 Oct 2026, 08:14 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 3.0.3.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <3.0.3
Fixed in
  • 3.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 3.0.3. Users should upgrade to version 3.0.3 or later to remediate this vulnerability. Until upgraded, avoid passing untrusted or attacker-influenced data as the refspec argument to Remote.pull().

Description

GitPython's Remote.pull() method improperly handles the positional refspec argument, allowing an attacker to inject a --upload-pack option that bypasses the unsafe-option guard. This leads to arbitrary command execution with the privileges of the calling process when pulling from local-path or SSH transports. The vulnerability affects versions from 2.1.0 up to but not including 3.0.3 and is fixed in version 3.0.3.

References

Community reviews

Loading reviews…