Skip to main content
VulnerabilityPublished Updated

CVE-2026-67324: Mistral vibe · GitPython unsafe clone option gate bypass through joined short options

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-67324· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.21.0 or 2.10.0 as a priority.

Data as of 30 Oct 2026, 08:01 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.21.0, 2.10.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.21.0 or 2.10.0.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.9.5 <2.10.0
  • >=2.18.0 <2.21.0
Fixed in
  • 2.10.0
  • 2.21.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython versions 2.10.0 and 2.21.0 that correctly parses and canonicalizes joined short options such as '-uVALUE' and '-cKEY=VALUE' before checking against the unsafe option set. Users should upgrade to these fixed versions to prevent this bypass. Until patched, avoid passing untrusted input to the multi_options parameter or explicitly set allow_unsafe_options=True only when safe. The vendor advisory confirms the fix is available; no additional action is required beyond upgrading.

Description

GitPython version 3.1.50 contains a vulnerability where the unsafe clone option gate can be bypassed using joined short options such as '-u<helper>'. This bypass allows execution of local commands via Git's upload-pack clone option despite the default protection that blocks unsafe options unless explicitly allowed. The issue arises because the canonicalization of joined short options does not correctly identify them as unsafe, permitting execution of potentially malicious helper commands during cloning.

References

Community reviews

Loading reviews…