CVE-2026-59924: Mistune · Arbitrary File Read via Include directive path traversal
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 4.6.1 when convenient.
Data as of 30 Oct 2026, 09:02 UTC
- Patch
- Available – fixed in 4.6.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in jupyterlab version 4.6.1. Users should upgrade to this version or later to remediate the vulnerability. The recommended fix involves validating the resolved include path to ensure it remains within an allowed base directory before opening the file. Until patched, avoid processing untrusted markdown files with the Include directive enabled.
Description
A path traversal vulnerability exists in the mistune library's Include directive when processing markdown files using md.read(). This flaw allows crafted include paths to access files outside the intended markdown directory. The issue arises because the resolved file path is not verified to remain within a trusted base directory, enabling traversal sequences like ../ to escape the intended folder. Applications that process untrusted markdown with this directive enabled may inadvertently expose sensitive files. The vulnerability affects jupyterlab versions from 1.2.0 up to but not including 4.6.1. A fix is available in version 4.6.1.
References
- github.com/lepture/mistune/security/advisories/GHSA-r4rv-85jg-w4mf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59924 (opens in a new tab)
- github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993 (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/lepture/mistune/releases/tag/v3.3.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/mistune/PYSEC-2026-2212.yaml (opens in a new tab)