Skip to main content
CVE-2026-115353VulnerabilityPublished Updated

Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to

Affects mistuneSource GCVE Database

0
Authoritative record:CVE-2026-115353· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 3.3.0 : patch mistune as a priority.

Data as of 28 Oct 2026, 23:11 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10mistunepkg:deb/ubuntu/mistune?arch=source&distro=stonkingOther threatsAffected
  • =3.1.4-1
Fixed in–
Ubuntu 26.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=resoluteOther threatsAffected
  • =3.1.3-1
  • =3.1.4-1
Fixed in–
Ubuntu 24.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=nobleOther threatsAffected
  • =2.0.4-2
  • =3.0.2-1
Fixed in–
Ubuntu 22.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=jammyOther threatsAffected
  • =0.8.4-4
  • =0.8.4-5
  • =2.0.0-1+really0.8.4-1
Fixed in–
Ubuntu 20.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=focalOther threatsAffected
  • =0.8.4-1
  • =0.8.4-2
Fixed in–
Ubuntu 18.04 LTSmistunepkg:deb/ubuntu/mistune?arch=source&distro=bionicOther threatsAffected
  • 0.7.4-1 – 0.8.3-2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Mistune version 3.3.0 and later. Users should upgrade to version 3.3.0 or newer to remediate this vulnerability. Until upgrading, avoid processing untrusted markdown content with the vulnerable include directive.

Description

Mistune versions before 3.3.0 have a path traversal vulnerability in the RST include directive. This flaw allows attackers to craft markdown with include directives that reference relative or absolute paths, enabling them to read arbitrary files. Sensitive files such as credentials or environment data can be exposed in the rendered HTML output. The vulnerability has a high severity with a CVSS score of 8.6.

References

Community reviews

Loading reviews…