CVE-2026-59927: Mistune directives/include · mutual `
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.6.1 when convenient.
Data as of 30 Oct 2026, 09:02 UTC
- Patch
- Available – fixed in 4.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in mistune version 4.6.1 that fixes the vulnerability by adding detection of indirect include cycles to prevent infinite recursion. Users should upgrade to version 4.6.1 or later. Until patched, applications should consider restricting user ability to upload or include arbitrary markdown files or implement application-level checks to prevent mutual includes. The vendor advisory confirms the fix is available and recommends upgrading.
Description
CVE-2026-59927 is a vulnerability in the mistune Markdown renderer's Include directive that allows uncontrolled recursion via mutual includes of markdown files. The directive only detects direct self-inclusion but fails to detect indirect cycles where two or more files include each other. This leads to unbounded recursion until Python's recursion limit is exceeded, causing a RecursionError that crashes the rendering process. This can be exploited by an attacker who can upload or control markdown files to cause denial of service by crashing the renderer. The issue affects mistune versions used in jupyterlab from 1.2.0 up to but not including 4.6.1. A fix is available in version 4.6.1 that adds cycle detection to prevent infinite recursion.
References
- github.com/lepture/mistune/security/advisories/GHSA-8mpj-m6qm-5qr8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59927 (opens in a new tab)
- github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993 (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/lepture/mistune/releases/tag/v3.3.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/mistune/PYSEC-2026-2215.yaml (opens in a new tab)