CVE-2026-59925: Mistune inline_parser · quadratic-time parsing on long runs of `**x**` and `***x***` emphasis pairs
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.6.1 soon.
Data as of 30 Oct 2026, 09:01 UTC
- Patch
- Available – fixed in 4.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Mistune version 4.6.1 that addresses this vulnerability. Users should upgrade to version 4.6.1 or later to mitigate the issue. The fix involves limiting the number of simultaneously tracked unmatched emphasis markers or rewriting the emphasis parsing logic to a delimiter-stack approach to ensure linear-time parsing. No additional mitigation steps are required if the patched version is deployed.
Description
CVE-2026-59925 is a high-severity algorithmic-complexity denial-of-service vulnerability in the Mistune markdown parser's core emphasis parsing. The parser performs quadratic-time work when processing long sequences of well-formed '**x**' or '***x***' emphasis pairs, causing excessive CPU usage. This affects the default Mistune configuration without requiring any plugins. The vulnerability has been confirmed in Mistune versions used by JupyterLab from 1.2.0 up to but not including 4.6.1. A fix is available in version 4.6.1.
References
- github.com/lepture/mistune/security/advisories/GHSA-4j32-57v6-6g45 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59925 (opens in a new tab)
- github.com/lepture/mistune/commit/5de41fb8e527004dbc363e047a3c380c9288c74f (opens in a new tab)
- github.com/lepture/mistune (opens in a new tab)
- github.com/lepture/mistune/releases/tag/v3.3.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/mistune/PYSEC-2026-2213.yaml (opens in a new tab)