Skip to main content
VulnerabilityPublished

CVE-2026-115355: Mistune · Path Traversal and XSS in Include directive

Affects iredisSource GCVE Database

0
Authoritative record:CVE-2026-115355· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.16.1_3 soon.

Data as of 27 Oct 2026, 06:58 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.16.1_3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade iredis to 1.16.1_3.

Affected software

ProductAffectedFixed in
Homebrewiredispkg:brew/iredisOther threatsAffected
  • >=1.11.0 <1.16.1_3
Fixed in
  • 1.16.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Mistune to version 1.16.1_3 or later where the vulnerability is fixed. Since the Include plugin must be explicitly enabled to be vulnerable, disabling this plugin if not needed also mitigates the risk. No other specific mitigations are indicated.

Description

A vulnerability in the Include directive of Mistune allows path traversal via '../' sequences to read arbitrary files outside the intended directory. Additionally, error messages and included file contents are rendered without HTML escaping, causing cross-site scripting (XSS) even when escaping is enabled. This affects versions from 1.11.0 up to but not including 1.16.1_3. The Include plugin must be explicitly enabled to be vulnerable.

References

Community reviews

Loading reviews…