Skip to main content
VulnerabilityPublished Updated

CVE-2026-59926: Mistune · XSS via unescaped class option in Admonition directive

Affects jupyterlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-59926· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.6.1 when convenient.

Data as of 30 Oct 2026, 09:02 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.1.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=1.2.0 <4.6.1
Fixed in
  • 4.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade JupyterLab to version 4.6.1 or later to remediate this vulnerability. Applying this official fix eliminates the risk of XSS via the Admonition directive's class option. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-59926 is a medium severity vulnerability in the Mistune library used by JupyterLab. The vulnerability arises from improper escaping of the :class: option in the Admonition directive, allowing cross-site scripting (XSS) via attribute injection. This occurs even when HTMLRenderer is configured to escape content. The flaw affects JupyterLab versions from 1.2.0 up to but not including 4.6.1. A fix is available in version 4.6.1.

References

Community reviews

Loading reviews…