CVE-2025-11200: MLflow Weak Password Requirements Authentication Bypass Vulnerability
Affects mlflowSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 2.22.0rc0 soon.
Data as of 4 Nov 2026, 18:07 UTC
- Patch
- Available – fixed in 2.22.0rc0
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade mlflow to 2.22.0rc0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPImlflow | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in MLflow version 2.22.0rc0. Users should upgrade to this version or later to remediate the vulnerability. Since this is an authentication bypass due to weak password requirements, applying the official fix is the primary mitigation. No additional vendor advisories indicate alternative mitigations or that no action is required.
Description
CVE-2025-11200 is a high-severity vulnerability in MLflow versions prior to 2.22.0rc0 that allows remote attackers to bypass authentication due to weak password requirements. Exploitation does not require prior authentication. The flaw arises from insufficient password strength enforcement, enabling attackers to gain unauthorized access. A fix is available in version 2.22.0rc0.