Skip to main content
VulnerabilityPublished Updated

CVE-2026-102010: gcc-toolset-15-gcc security update

Affects gcc-toolset-15-gccSource GCVE Database

0
Compare
Authoritative record:CVE-2026-102010· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade to 15.2.1-7.1.el10_2.alma.1 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.0
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.2.1-7.1.el10_2.alma.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 15.2.1-7.1.el10_2.alma.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10gcc-toolset-15-gccAffected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1
AlmaLinux 10gcc-toolset-15-gcc-c++Affected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1
AlmaLinux 10gcc-toolset-15-gcc-gfortranAffected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1
AlmaLinux 10gcc-toolset-15-gcc-plugin-annobinAffected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1
AlmaLinux 10gcc-toolset-15-gcc-plugin-develAffected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1
AlmaLinux 10gcc-toolset-15-libasan-develAffected
  • <15.2.1-7.1.el10_2.alma.1
Fixed in
  • 15.2.1-7.1.el10_2.alma.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in gcc-toolset-15-gcc version 15.2.1-7.1.el10_2.alma.1. Users should update affected systems to this version or later to remediate the vulnerability. Follow Red Hat's official update instructions as detailed in their advisory.

Description

A use-after-free vulnerability in the gcc-toolset-15-gcc package (GNU Compiler Collection version 15) allows denial of service via the binary heap erase_if function. This issue is addressed in version 15.2.1-7.1.el10_2.alma.1. The vulnerability is rated with moderate severity by Red Hat.

References

Community reviews

Loading reviews…