Skip to main content
VulnerabilityPublished Updated

CVE-2026-88807: libXrender security update

Affects libXrenderSource GCVE Database

0
Compare
Authoritative record:CVE-2026-88807· High 8.9

Not known to be exploited · CVSS 8.9 High : upgrade to 0.9.11-8.el10_2.1 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.11-8.el10_2.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 0.9.11-8.el10_2.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10libXrenderAffected
  • <0.9.11-8.el10_2.1
Fixed in
  • 0.9.11-8.el10_2.1
AlmaLinux 10libXrender-develAffected
  • <0.9.11-8.el10_2.1
Fixed in
  • 0.9.11-8.el10_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libXrender version 0.9.11-8.el10_2.1. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory and article https://access.redhat.com/articles/11258 for detailed update instructions. No additional mitigation steps are indicated beyond applying the official patch.

Description

A heap overflow vulnerability in the libXrender library's RenderQueryPictFormats function allows for potential code injection. This security flaw affects versions of libXrender prior to 0.9.11-8.el10_2.1. Red Hat has issued an important security update to address this issue in Red Hat Enterprise Linux 10 and related variants.

References

Community reviews

Loading reviews…