Skip to main content
VulnerabilityPublished

CVE-2025-14087: glib2 security update

Affects glib2Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-14087· Medium 5.6

Not known to be exploited · CVSS 5.6 Medium : upgrade to 2.56.4-169.el8_10 when convenient.

Data as of 27 Oct 2026, 04:14 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.56.4-169.el8_10
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 2.56.4-169.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8glib2Affected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10
AlmaLinux 8glib2-develAffected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10
AlmaLinux 8glib2-docAffected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10
AlmaLinux 8glib2-famAffected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10
AlmaLinux 8glib2-staticAffected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10
AlmaLinux 8glib2-testsAffected
  • <2.56.4-169.el8_10
Fixed in
  • 2.56.4-169.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official glib2 update to version 2.56.4-169.el8_10 or later as provided by Red Hat Enterprise Linux 8 advisories. This update fixes the buffer underflow and integer overflow vulnerabilities. No additional mitigation steps are indicated by the vendor.

Description

A security update for glib2 addresses a buffer underflow vulnerability in the GVariant parser that leads to heap corruption (CVE-2025-14087), along with an integer overflow in GLib GIO attribute escaping causing a heap buffer overflow (CVE-2025-14512). These issues affect core components used by GNOME and other applications relying on GLib. The vulnerabilities are rated as Moderate severity by Red Hat. A fixed version 2.56.4-169.el8_10 is available for Red Hat Enterprise Linux 8 and related distributions.

References

Community reviews

Loading reviews…